FAQs - Suporte técnico

RM - Frame - Falha ao executar relatórios

Ocorrência
Ao executar alguns processos no RM, como por exemplo, gerar relatório .Net é apresentada falha abaixo:

Exemplo de erro 1:

Access to the path '10.0.02.2\rm-share-files\logs\Processos\Logs\RptActionProcGenerateReport\9ef2133e-ef65-48ca-9e70-ead7a84730b2\' is denied.



Exemplo Erro 2:

Could not find file ‘\\SRVTOTVSAPP01\ARQUIVOS\e8d9e2d2-9ª2c-411ª-80f0-1736b34e8c3c.tmp’

Exemplo Erro 3:

Erro ao salvar o arquivo.
Não foi possível localizar o arquivo 'C:\totvs\CorporeRM\RM.Net\Arquivos\beb1cc5d-2a09-4a2f-bf0b-186d8d9facf1.tmp'.



Ambiente
RM - Framework  - todas as versões 

 

Causa
Inconsistência na configuração das TAGs FileServerPath e LogPath ou falta de configuração da impressora. 

 

Solução
Para solucionar essa ocorrência, configure as TAG FileServerPath e LogPath em seus servidores de App e JOB, apontando para uma unica pasta compartilhada na rede; aplique as configurações de impressora, conforme descrito abaixo:

Importante
O caminho da pasta configurado dentro das TAGs deve ser o caminho do compartilhamento.
Exemplo: \\NomeServidor\NomePasta

Saiba mais
Para informações sobre como configurar as TAG FileServerPath e LogPath, acesse o documento Configurando FileServerPath e LogPath.

Na máquina que apresenta a inconsistência realize a configuração do documento Configuração de Impressora Padrão. Em ambiente 3 ou N camadas esta configuração deve ser executada nos servidores de JOB e App.


Importante
Em alguns casos, a falha é aleatória (hora ocorre, hora não ocorre). Essa situação é apresentada quando um dos servidores de APP ou Jobs não está devidamente configurado. 
Para identificá-lo, siga os passos abaixo:

  1. Assim que ocorrer a falha, acesse o gerenciamento de jobs;
  2. Selecione o job executado com o falha;
  3. Clique na aba Identificação, conforme exemplo abaixo:
  4. Avalie as configurações das tags FileServerPath e LogPath e configurações de impressora do servidor apresentado.
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