Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Framework RM - BD - Erro de Tempory table resouce limit

Framework - Framework RM - BD - Erro de Tempory table resouce limit

time.png Tempo aproximado para leitura: 00:02:40 min

Ocorrência
Ao acessar o executável do módulo (Delphi),  é apresentada a seguinte inconsistência:
Tempory table resouce limit

Ambiente
Framework - Framework (Linha RM) - Banco de Dados - Todas as versões

Causa
Necessidade de ajustes nas parametrizações do BDE.

Solução

É orientado realizar as seguintes configurações no BDE, acessando o caminho abaixo:

  • Acesse o BDE;
  • Vá na guia de Configurações;
  • Selecione a opção de Drivers;
  • Opção Native;
  • Escolha de acordo com o provider utilizado para conexão MSSQL ou Oracle  ou SQL Server ou SQL Server Native Client (xx)
  • Na guia de Definições, atualize os valores dos campos Blob Size e Blob to Cache:
    - Blob Size = 512
    - Blobs To Cache = 512

Sem_t_tulo.png

 

  • Vá aba Databases selecione a base de dados em questão
  • Na guia de Definições, atualize os valores dos campos Blob Size e Blob to Cache
    - Blob Size = 999
    - Blobs To Cache = 768

Sem_t_tulo2.png

Estas configurações podem ser ajustadas para um limite superior sempre em múltiplos de 64 visando a correção do incidente, obedecendo os limites abaixo:

Blob Size: 999
Blobs To cache: 65536

 

Em seguida realize os passos abaixo: 

  1. Localize o arquivo C:\PDOXUSRS.NET e nas Propriedades do mesmo acesse a guia Segurança e dê acesso ao usuário para alterar o arquivo.
  2. Localize o arquivo C:\PDOXUSRS.NET e nas Propriedades do mesmo acessar a guia Geral e verificar se o mesmo esta marcado como Somente Leitura ou Oculto.
  3. No BDE dentro da guia Configuration  acessar o menu Configuration / Drivers / Native / PARADOX e limpar o campo NET DIR

Importante
Caso a inconsistência persista, favor informar no campo NET DIR o diretório C:\Totvs

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _