FAQs - Suporte técnico

DS - FRW - Problemas de acentuação nos e-mails enviados pelo Datasul Mail Service e programas Web/HTML

Ocorrência
Problemas de acentuação e caracteres especiais nos e-mails enviados pelo Datasul Mail Service

Problemas de acentuação com programas Web/Html.

Ambiente
Datasul 12 - Framework - 12.1.15 ou superior

Causa
O Datasul 12 não está utilizando a codificação correta (UTF-8).

Solução
Altere a codificação para UTF-8:
1. Pare o serviço do Jboss;
2. Edite o arquivo "...\ServidorAplicacao\jboss-4.2.3.GA\bin\run.bat" para Windows ou ".../ServidorAplicacao/jboss-4.2.3.GA/bin/run.conf" para Linux;
3. Insira no arquivo os parâmetros conforme o sistema operacional:

Windows:
rem JVM encoding parameters
set JAVA_OPTS=%JAVA_OPTS% -Dsun.jnu.encoding=UTF-8 -Dfile.encoding=UTF-8
Linux:
# JVM encoding parameters
JAVA_OPTS="$JAVA_OPTS -Dsun.jnu.encoding=UTF-8 -Dfile.encoding=UTF-8"

4. Salve o arquivo e reinicie o serviço do Jboss.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _