FAQs - Suporte técnico

RM - Frame - Várias execuções do RM.Host.JobRunner

Ocorrência
Após realizar a instalação da biblioteca RM a partir da 12.1.19 são criados vários processo do RM.Host.JobRunner.


Ambiente
RM - Framework - A partir do release 12.1.19.


Causa
A partir do release 12.1.19 foi criado o Pool de Jobs, para que o serviço do JobRunner já fique ativo e quando um processo for executado, não haja atraso causado pela inicialização do JobRunner. O processo de Pool de Jobs foi criado pois em alguns ambientes foi percebido um atraso entorno de 3 segundos entre o momento da solicitação de execução do processo, até o inicio da execução através do JobRunner.
A partir da versão 12.1.19 o funcionamento do JobRunner passa a ser da seguinte forma:
Para cada execução simultânea é criada a Thread e alocados aproximadamente 30MB de memória, apta para execução dos processos, para cada Alias criado no Ambiente (Alias.dat). Através do Gerenciador de Tarefas é possível visualizar várias execuções do processo RM.Host.JobRunner.
Exemplo: 2 Serviço do Host, 3 execuções simultâneas e dois Alias (base de produção e base teste), serão criadas 12 Threads.


Solução
Caso queira desabilitar este comportamento, a partir do patch 12.1.19.111, foi liberado parâmetro para desabilitar procedimento:

  1. Acessar o caminho UNIDADE:\TOTVS\CorporeRM\RM.Net;
  2. Acessar o aplicativo RM.AliasManager.exe;
  3. Acessar a aba Serviços da base desejada;
  4. Desabilitar o parâmetro Habilita pool de Processos;
  5. Após desabilitar o mesmo, é necessário reiniciar serviço de host para que alteração seja realizada.

Saiba mais
Para mais informações acesse link abaixo:
http://tdn.totvs.com/display/public/LRM/Gerenciamento+de+Alias



Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _