Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha RM - Frame - Várias execuções JobRunner

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência

Após realizar a instalação da biblioteca RM a partir da versão 12.1.19 são criados vários processos do RM.Host.JobRunner.exe.


Ambiente
Framework - Linha RM - Frame - A partir do release 12.1.19


Causa
A partir do release 12.1.19 foi criado o pool de jobs, para que o serviço do jobrunner já fique ativo e quando um processo for executado, não haja atraso causado pela inicialização do jobrunner.

O processo de pool de jobs foi criado pois em alguns ambientes foi percebido um atraso em torno de 3 segundos entre o momento da solicitação de execução do processo, até o inicio da execução através do jobrunner.

A partir da versão 12.1.19 o funcionamento do jobrunner passa a ser da seguinte forma:
Para cada execução simultânea é criada a thread e alocados aproximadamente 30MB de memória, apta para execução dos processos, para cada alias criado no ambiente (Alias.dat). Através do Gerenciador de Tarefas é possível visualizar várias execuções do processo RM.Host.JobRunner.

Exemplo: 2 serviços do Host, 3 execuções simultâneas e dois alias (base de produção e base teste), serão criadas 12 threads.


Solução
Caso deseje desabilitar este comportamento, a partir do patch 12.1.19.111, foi liberado parâmetro para desabilitar o pool de processos, para tanto siga os passos abaixo: 

  1. Acessar o caminho UNIDADE:\TOTVS\CorporeRM\RM.Net;
  2. Acessar o aplicativo RM.AliasManager.exe;

  3. Acessar a aba Serviços da base desejada;



  4. Desabilitar o parâmetro Habilita pool de Processos;



    Observação: caso a flag Habilitar processamento de jobs esteja desmarcada e a flag Habilita pool de processos esteja marcada, para desativar o recurso, marque a flag Habilitar processamento de jobs para que seja possível desmarcar o parâmetro Habilita pool de processos.
  5. Após desabilitar o mesmo, é necessário reiniciar serviço de host para que a alteração seja realizada.

Saiba mais
Para mais informações acesse link abaixo:  
Gerenciamento de Alias



Esse artigo foi útil?
Usuários que acharam isso útil: 2 de 2

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _