FAQs - Suporte técnico

RM - BD - Erro "NTWDBLIB.DLL - Vendor initialization failed"

Ocorrência
Ao acessar o BDE e tentar fazer a conexão com o Banco, ocorre o erro abaixo:

Vendor initialization failed
Cannot load an IDAPI service library
File: NTWDBLIB.DLL



Ambiente
RM - Tecnologia - Todas as versões

Causa
O BDE não conseguiu carregar o arquivo NTWDBLIB.DLL.

Solução
Este erro significa que o BDE não conseguiu carregar o arquivo NTWDBLIB.DLL* que se encontra no diretório de sistema \Windows\System32

Nas versões 2005 e 2008 do SQL Server este erro não está relacionado a instalação do client, pois esta DLL é uma DLL do SQL Server 2000, neste caso, a DLL consta nos instaladores da biblioteca RM.

Neste caso você deverá instalar a biblioteca RM copiar a DLL NTWDBLIB.DLL da pasta "diretório_de_instalação"\CorporeRM\API ou "diretório_de_instalação"\totvs\CorporeRM\API e copiá-la para a pasta c:\Windows\System32.

*NTWDBLIB.DLL: Cliente 32 bits do SQL Server (DB-Library), responsável pela comunicação entre o cliente (Estação) e o servidor de Banco de Dados.

 

Para Mais Informações

 *COMUNIDADE  R@Tecnologia
Canais de Atendimento:
Chamado: Através do Portal Totvs: www.suporte.totvs.com.br
Telefônico: 4003-0015 Escolhendo as opções 2 – (Software), 2 – (Suporte Técnico), 3 – (RM), 8 – (Tecnologia), 2 – (Banco de Dados);

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _