FAQs - Suporte técnico

RM - BD - Erro "An error occurred while attempting to initialize the Borland Datanase Engine (error $210D)"


Ocorrência
Ao acessar o executável do módulo (Delphi), o sistema é apresentada  seguinte inconsistência:

"An error occurred while attempting to initialize the Borland Datanase Engine (error $210D)"


Ambiente
Aplicações Delphi


Causa
Os erros $210D e $2501 são decorrentes de conflitos na alocação de recursos de memória pelo Windows. Nas versões XP e Vista o endereçamento padrão para o BDE era bastante e não havia necessidade de realizar maiores ajustes no BDE para utilizar várias instâncias do BDE simultaneamente sem que houvesse conflitos nos recursos alocados..

Solução

Verifique se o BDE está fechado, antes de acessar a aplicação Delphi.

Caso a inconsistência persista, as configurações devem ser realizadas conforme seguinte link:

http://tdn.totvs.com/display/public/rm/BDE+-+%24210D+e+%242501

Recomendo que mantenha o valor 7F00 para o campo SHAREDMEMLOCATE e SHAREDMEMSIZE 205. Caso a inconsistência persista, desative o recurso de ASLR, incluindo o RM.EXE

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras clique aqui.

TOTVS

X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _