Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Backoffice RM - Integração - WebServices - Orientação para autenticação básica

Cross Segmentos - Backoffice RM - Integração - WebServices - Orientação para autenticação básica

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência 

Ao tentar consumir Web Services é apresentado erro de autenticação.Como exemplo utilizamos a mensagem apresentada na ferramenta SoapUI.

Ambiente

Cross Segmentos - Backoffice RM - Integrações - Todas as Versões.

Causa

A partir da versão 12.1.18 é exigida autenticação básica para consumo de Web Services. Esse ajuste foi realizado nas versões mais atuais por questões de segurança na autenticação básica dos recursos do RM.

 

Solução

Basta configurar na ferramenta a opção para aceitar a autenticação básica, segue exemplo da configuração na ferramenta SoapUI:

1. Acesse o menu de preferências do SoapUI;

 

2. Em caso de já haver algum projeto salvo sem as configurações de autenticação, a configuração também poderá ser feita diretamente no projeto:

 

 

Acesse nossa Central de Atendimento, selecione o Produto e verifique nossos Artigos para se Auto Atender.

Esse artigo foi útil?
Usuários que acharam isso útil: 3 de 3

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _