FAQs - Suporte técnico

RM - BD - Erro "Atributo de cadeia de caracteres de conexão inválido"



Ocorrência
Erro ao acessar o modulo Delphi:

"Atributo de cadeia de caracteres de conexão inválido"


Ambiente
Aplicações Delphi
A partir do SQL Server 2012.

Causa
Parametrização ODBC realizada incorretamente.

Solução

Nesse caso, favor realizar a seguinte verificação:

 

  1. No BDE clique com o botão direito sobre a guia ‘DataBase’ e em seguida em ‘ODBC Adminstrator’;
  2. Nas guias ‘DNS de Usuário’ (User DSN) e ‘DNS de Sistema’ (system DSN) verifique se consta uma conexão com o mesmo Alias da guia DataBase, caso positivo realize a sua exclusão do item na guia ‘DNS de Usuário’

A conexão deve ser criada somente na guia ‘System DSN’ ou ‘Fonte de Dados de Sistema’ as guias de usuários não devem ser utilizadas.

O SQL 2012 ou superior deve-se utilizar o nível de compatibilidade 100. Verifique o nível de compatibilidade e as seguintes configurações do ODBC:

 http://tdn.totvs.com/display/public/rm/SQL+Server+-+ODBC+SQL+Server+2012

 Observações:

  • Na seleção do Drive do ODBC deve-se utilizar a opção SQL NATIVE CLIENT 10 ou 11;
  • No campo Description favor informar o nome do Base de Dados que consta no SQL Server;
  • No campo Server favor informar o valor apresentado no resultado da seguinte consulta SQL - select SERVERPROPERTY ('Servername')
  • No campo Change the default database to: selecione a Base de Dados em questão.
  • Verifique também se o método de autenticação da instância SQL está definido como SQL Server and Windows Authentication Mode.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _