Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Framework RM - BD - Erro de Execução da Procedure SP_REMOVETRIGGERS

Framework - Framework RM - BD - Erro de Execução da Procedure SP_REMOVETRIGGERS

time.png Tempo aproximado para leitura: 00:01:52 min

Ocorrência
O erro abaixo é apresentado na Execução da Procedure SP_REMOVETRIGGERS em base Oracle:
Não foi possível remover as triggers do Log de Auditoria!


Ambiente
Framework - Framework (Linha RM) - Banco de Dados - A partir da 12.1.27

Causa
A Procedure pode não existir na base, ou o usuário não tem permissão de executá-la.

Solução
Neste tipo de inconsistência temos que realizar os seguintes passos: 

  • Verificar se a PROCEDURE existe na Base:
SELECT * FROM ALL_PROCEDURES WHERE OWNER = 'RM' AND OBJECT_NAME = 'SP_REMOVETRIGGERS'
  • Verifica as permissões do usuário referente as Triggers:
SELECT * FROM

(SELECT PRIVILEGE FROM SYS.DBA_SYS_PRIVS WHERE GRANTEE = 'RM'

UNION

SELECT PRIVILEGE  FROM DBA_ROLE_PRIVS RP JOIN ROLE_SYS_PRIVS RSP ON (RP.GRANTED_ROLE = RSP.ROLE) WHERE RP.GRANTEE = 'RM' ORDER BY 1) TEMP

WHERE PRIVILEGE LIKE '%TRIGGER%';

  • Caso a Procedure exista e o usuário RM não possua as permissões para manipular as Triggers, gentileza executar os GRANTS abaixo antes da Atualização da Base de Dados utilizando o usuário SYS:
GRANT CONNECT, RESOURCE, CREATE VIEW TO RM;

GRANT SELECT ANY DICTIONARY TO RM;

GRANT CONNECT,CREATE SYNONYM TO SYSDBA;

GRANT EXECUTE ON DBMS_SYS_SQL TO RM;

GRANT EXECUTE ON DBMS_SQL TO RM;

GRANT CREATE TRIGGER TO RM;

GRANT SELECT ON V_$SESSION TO RM;

GRANT SELECT ON V_$STATNAME TO RM;

GRANT SELECT ON V_$SESSTAT TO RM;

GRANT SELECT ON V_$INSTANCE TO RM;

 

Importante
Caso a Procedure não exista na base de dados, favor entrar em contato com o Suporte de Banco de Dados.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _