Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Backoffice Protheus - SIGACRM - Erro na inclusão da oportunidade com o campo AD9_NOMCON

Cross Segmentos - Backoffice Protheus - SIGACRM - Erro na inclusão da oportunidade com o campo AD9_NOMCON


Ocorrência

Ao incluir uma oportunidade, ocorre o erro: variable does not exist ACOLS on {|a,b,c| FWInitCpo(a,b,c),xRet:=(Posicione( "SU5", 1, xFilial( "SU5" ) + GDFieldGet( "AD9_CODCON", Len( aCols ) ), "U5_CONTAT" )),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }(PROTHEUSFUNCTIONMVC.PRX)

Ambiente

Cross Segmentos - Backoffice Protheus - SIGACRM - A partir da release 12

Causa

O erro ocorre por que o x3_relação do campo AD9_NOMCON está com a validação: (Posicione( "SU5", 1, xFilial( "SU5" ) + GDFieldGet( "AD9_CODCON", Len( aCols ) ), "U5_CONTAT" ).

 

Solução

Para solucionar essa ocorrência, ajuste as informações no campo: AD9_NOMCON -X3_RELAÇÃO para: IIF(!INCLUI,AllTrim(Posicione("SU5",1,xFilial("SU5")+AD9->AD9_CODCON,"U5_CONTAT")),"") que é o padrão do dicionário do sistema , para que o erro deixe de ocorrer.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _