FAQs - Suporte técnico

MP-FAT-Array out of bounds (0 of 107) on Aftercols (MATA410.prx)


Ocorrência

Ao copiar o pedido, gera o erro: Ao copiar o pedido de venda gera error.log - array out of bounds ( 0 of 107 )  on AFTERCOLS(MATA410.PRX).

Ambiente

Microsiga Protheus -  a partir da versão 11.80.

Causa

Este erro ocorre quando os campos que fazem parte do array, não existem no dicionário de dados ou não estão marcados o uso.

A grande parte das ocorrências estão relacionadas aos campos C6_PEDCLI e/ou C6_ENTREG não estão em uso ou não existem no SX3 ou no banco de dados (tabela SC6).

Outras ocorrências deste erro foram relacionadas aos campos C6_NFORI e/ou C6_SERIORIG, que não estavam em uso no SX3 e eram requeridos no processo.

Também pode ocorrer se o campo C6_IDENTB6 não estiver com o seu uso marcado,este campo é requerido na função Aftercols, assim também como os campo C6_GRADEC6_PRODUTOC6_QTDLIB.


Solução

Para solucionar essas ocorrências, realize os seguintes passos:
1. Verifique se via configurador, se os campos estão em uso;
2. Verifique se os campos existem na tabela SX3;
3. Verifique se os campos existem dentro da tabela SC6.

Obs: Caso seja necessário a criação dos campos no ambiente, siga as intruções da FAQ: Array out of bounds (0 of 107) on Aftercols (MATA410.prx) ou baixe o dicionário de dados do portal do cliente , efetuando os procedimentos de atualização de dicionário via upddistr para ajustar o ambiente.

Na versão 12, o erro é este:

array out of bounds ( 0 of 55 )  on AFTERCOLS(MATN410.PRW), porém, a solução é a mesma.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _