Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Array out of bounds (0 of 107) on Aftercols (MATA410.prx)

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao copiar o pedido, gera o erro: Ao copiar o pedido de venda gera error.log - array out of bounds ( 0 of 107 )  on AFTERCOLS(MATA410.PRX).

Ambiente

Cross Segmentos-TOTVS Backoffice (Linha Protheus)-Faturamento (SIGAFAT) - todas as versões.

Causa

Este erro ocorre quando os campos que fazem parte do array, não existem no dicionário de dados ou não estão marcados o uso.

A grande parte das ocorrências estão relacionadas aos campos C6_PEDCLI e/ou C6_ENTREG não estão em uso ou não existem no SX3 ou no banco de dados (tabela SC6).

Outras ocorrências deste erro foram relacionadas aos campos C6_NFORI e/ou C6_SERIORIG, que não estavam em uso no SX3 e eram requeridos no processo.

Também pode ocorrer se o campo C6_IDENTB6 não estiver com o seu uso marcado, este campo é requerido na função Aftercols, assim também como os campo C6_GRADEC6_PRODUTOC6_QTDLIB.

Também valide o nível de campo, que quando mudado do padrão 1, pode gerar problemas de array.


Solução

Para solucionar essas ocorrências, realize os seguintes passos:
1. Verifique se via configurador, se os campos estão em uso;
2. Verifique se os campos existem na tabela SX3;
3. Verifique se os campos existem dentro da tabela SC6.

 

Obs: Para o caso de falta de campo no Dicionário de Dados, é necessário efetuar o download do Dicionário de Dados no portal do cliente, conforme a sua release de uso e posteriormente, processar o UPDDISTR para que o ambiente assuma a atualização de Dicionário de Dados.

Feito o procedimento, reinicie o Protheus e efetue o processo novamente.

Importante: Na versão 12, o erro na função AFTERCOLS é "Array out of bounds ( 0 of 55 )  on AFTERCOLS(MATN410.PRW)", porém, as verificações de causa e a solução a ser aplicada, é exatamente a mesma.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _