FAQs - Suporte técnico

MP-FAT-Argument #1 error, expected C->N, function AT on _FWMBPICTVAR(FWMBROWSE.PRW)

Ocorrência
Ao tentar acessar o cadastro do cliente, ocorre o erro: argument #1 error, expected C->N,  function AT on _FWMBPICTVAR(FWMBROWSE.PRW).


Ambiente
Microsiga Protheus - a partir da release 12.1.17.

Causa
O erro ocorre em situações que o cliente possui a validação X3_PICTVAR do campo A1_CGC incorreta, ou quando possui na sua estrutura SX3, a coluna X3_PICBRV preenchida ou quando há um erro de profile de usuário.

Solução

Para solucionar a ocorrência, valide o cenário do ambiente e  efetue o passo correspondente:

1- Para ajuste X3_PICTVAR incorreto no campo A1_CGC - ajuste a função PicCli para PicPes, deixando a função como PicPes(M->A1_PESSOA);

2- Para ajuste X3_PICBRV preenchida - limpe as informações da coluna;

3- Para ajuste de profile: efetue a manutenção, limpando os profiles de usuário.

Para maiores detalhes de como efetuar os procedimentos, acesse: argument #1 error, expected C->N, function AT on _FWMBPICTVAR(FWMBROWSE.PRW)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _