Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Linha RM - Fis - Timeout Expired

Cross Segmentos - Linha RM - Fis - Timeout Expired

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência

No módulo Fiscal, no processo de geração de rotinas, é apresentada a seguinte mensagem:
Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. 

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - TOTVS Gestão Fiscal - A partir da versão 12.1.

Causa
Este incidente ocorre, pois o framework da TOTVS tem um timeout default de 120 segundos para execução de comandos no banco de dados.

Solução
Para prevenir inconsistências de timeout, sugerimos aos clientes  aumentarem este tempo limite para 100000 segundos. Sendo assim, abaixo segue os passos para corrigir a inconsistência nas plataformas .NET e .DELPHI


Plataforma .Net:

01. Acessar os arquivos ".config", com os seguintes nomes: 
“RM.Host.exe.config”, “RM.Host.Service.exe.config” e "RM.Host.JobRunner.exe.config".
27-02-2018_12-14-21.jpg

Ao acessar os arquivos, deverá ser acrescentada a seguinte linha abaixo:
<add key="DBSCommandTimeout" value="100000" />

1.1. Após acrescentar a linha, o arquivo ficará conforme o exemplo abaixo:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="JobServer3Camadas" value="True" />
<add key="Port" value="1120" />
<add key="ActionsPath" value="C:\RM.Net\Bin" />
<add key="WorkflowEnabled" value="True" />
<add key="DBSCommandTimeout" value="100000" />
</appSettings>
<runtime>
<NetFx40_LegacySecurityPolicy enabled="true"/>
</runtime>
<startup>
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
</startup>
</configuration>

02. Depois de altera-los acrescentando a linha, deverá então salvar os arquivos “RM.Host.exe.config”, “RM.Host.Service.exe.config” e "RM.Host.JobRunner.exe.confige gerar novamente a rotina.

Plataforma .Delphi:

01. Realizar alteração do Timeout, acessando o Painel de Controles | BDE | MSSQL | Adminstrator CONNECT TIMEOUT = 7200 e TIMEOUT = 7200
28-02-2018_11-12-25.png

1.1. Logo após, grave as alterações e reinicie a aplicação.
28-02-2018_11-12-12.png

02. Feitas as alterações, gere novamente o processo ou rotina.


Saiba Mais
Para mais informações acesse Aumentar o Timeout da execução das sentenças SQL

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 2

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _