FAQs - Suporte técnico

MP - SIGACTB - Erro na exclusão da conta contábil - Invalid column name 'FB_CONTA'

Ocorrência
No módulo Contabilidade Gerencial, ao tentar realizar a exclusão da conta contábil é retornado a mensagem de erro: Invalid column name 'FB_CONTA'. (From tMSSQLConnection::GetQueryFile)

Thread ID [4776] User [Administrador] IO [2748] Tables [31] MaxTables [32] Comment [CTBA020 - TCPIP - ThreadID(116824)] Status [] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/DHD74B] DBThread [(SPID 190,199)] Started [14/02/2018 11:10:26] LastIO [14/02/2018 11:14:38] IP [127.0.0.1:9563] RCV [243550] SND [240223] TCBuild [20170202-20171123]
SELECT 1 REG FROM CT1010 DOM WHERE CT1_FILIAL = ' ' AND CT1_CONTA = '5101010001 ' AND EXISTS (SELECT 1 FROM SFB010 CDOM WHERE FB_FILIAL = '01 ' AND FB_CONTA = '5101010001 ' AND CDOM.D_E_L_E_T_ = ' ' ) on FORMCANDEL(MPPREPVALIDATION.PRW) 10/11/2017 15:09:28 line : 811

Ambiente
Protheus – Contabilidade Gerencial – A partir da versão 12 Release 12.1.17

Causa
Esse incidente ocorre, pois o relacionamento entre a tabela de plano de contas (CT1) e a tabela de Impostos Variáveis (SFB) não deve existir para a localidade BRASIL. O cadastro de Impostos Variáveis é utilizado somente fora do Brasil e devido a isto não devemos ter o relacionamento desta tabela vigente para esta localidade.


Solução
Para solucionar essa ocorrência, realize o seguinte procedimento: MP - SIGACTB - Ambiente desatualizado

 

IMPORTANTE: Caso o campo ainda exista na tabela de relacionamento (SX9), proceder com a manutenção manual do registro, apagando-a de sua tabela.o registro deve estar como X9_DOM = CT1_CONTA e X9_EXPCDOM = FB_CONTA. Caso exista outros relacionamento com esta tabela, proceder com a mesma orientação.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _