Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - EST - Chave Duplicada TXPRDRED

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - EST - Chave Duplicada TXPRDRED

time.png Tempo aproximado para leitura: 00:02:00min

Ocorrência
Ao cadastrar um novo produto é apresentado a mensagem:

Ambiente
Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento – A partir da 11.80.

Causa
O incidente é apresentado pois o valor atual do código reduzido é menor que o valor máximo encontrado na TPRODUTO para a coligada em questão. Com isso, ao salvar o produto o sistema está tentando gerar um valor de código reduzido automaticamente que já se encontra cadastrado na base de dados.

Solução
Para solucionar este problema deverá acertar o valor correspondente ao campo Código Reduzido da tabela GAUTOINC com o maior valor já cadastrado de Código Reduzido.

Para igualar os valores do MAX(CODIGOREDUZIDO) – Maior valor encontrado para o código reduzido na coligada - e da sequência atual nos parâmetros do módulo, basta executar a consulta abaixo:

SELECT MAX(CODIGOREDUZIDO) FROM TPRODUTO WHERE CODCOLPRD=X
Onde X é o código da coligada que está cadastrando o produto

De posse do último código reduzido, será necessário alterar a sequencial atual no parâmetro do módulo.

Para mais detalhes, acesse o link abaixo:
Violação da chave TXPRDRED ao cadastrar novo produto.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _