FAQs - Suporte técnico

MP - ERRORLOG0027 - GPER030 - Ao realizar impressão do recibo de pagamento (GPER030): THREAD ERROR "RC_EMPRESA": invalid identifier

Ocorrência  
Ao realizar impressão do recibo de pagamento (GPER030):
THREAD ERROR 'RC_EMPRESA': invalid identifier
( From tOracleConnection::GetQueryFile )
Thread ID [22186] User [CARLOS.CAZELATTO] IO [10304] Tables [34] MaxTables [34] Comment [GPER030 - TCPIP - ThreadID(6272)] Status [] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [ORACLE/DADOSADV] DBThread [(SID 75,22225,1)] Started [18/01/2018 14:41:34] LastIO [18/01/2018 14:45:34] IP [192.168.0.237:5123] RCV [145467] SND [1861830] TCBuild [20161016-20170530]


Causa
THREAD ERROR 'RC_EMPRESA': invalid identifier
 ( From tOracleConnection::GetQueryFile )
Thread ID [22186]    User [CARLOS.CAZELATTO]    IO [10304]    Tables [34]    MaxTables [34]    Comment [GPER030 - TCPIP - ThreadID(6272)]    Status []    SP [ ]    Traced [No]    SQLReplay [No]    InTran [No]    DBEnv [ORACLE/DADOSADV]    DBThread [(SID 75,22225,1)]    Started [18/01/2018 14:41:34]    LastIO [18/01/2018 14:45:34]    IP [192.168.0.237:5123]    RCV [145467]    SND [1861830]    TCBuild [20161016-20170530]   
SELECT RC_MAT,RC_PD,RC_TIPO1,RC_HORAS,RC_VALOR,RC_DATA,RC_SEMANA,RC_CC,RC_PARCELA,RC_TIPO2,RC_SEQ,RC_QTDSEM,RC_VALORBA,RC_CODB1T,RC_VNAOAPL,RC_DTREF,RC_PROCES,RC_PERIODO,RC_POSTO,RC_NUMID,RC_ROTEIR,RC_DEPTO,RC_ITEM,RC_IDCMPL,RC_CLVL,RC_LOTPLS,RC_CODRDA FROM SRC010 WHERE  RC_FILIAL = '01' AND RC_MAT = '000006' AND RC_PROCES = '00001' AND RC_ROTEIR = 'ADI' AND RC_PERIODO ||RC_SEMANA IN ('20180101') AND D_E_L_E_T_=' ' AND (RC_EMPRESA = ' ' OR RC_EMPRESA = '01') on RETORNAVERBASFUNC(GPER040.PRX) 05/01/2018 16:09:03 line : 3505

[TOTVS build: 7.00.131227A-20171002 NG]
Called from RETORNAVERBASFUNC(GPER040.PRX) 05/01/2018 16:09:03 line : 3505
Called from R030IMP(GPER030.PRX) 10/01/2018 16:08:01 line : 778
Called from {|lEnd| R030Imp(@lEnd,wnRel,cString,cMesAnoRef, .f. )}(GPER030.PRX) 10/01/2018 16:08:01 line : 778
Called from { || Eval( bAction, @lStop ),lStop := .t. , oDlg:End() }(APLIB080.PRW) 03/01/2018 17:40:20 line : 778
Called from ::MSDIALOG:ACTIVATE line : 778
Called from RPTSTATUS(APLIB080.PRW) 03/01/2018 17:40:20 line : 2213
Called from GPER030(GPER030.PRX) 10/01/2018 16:08:01 line : 317
Called from __EXECUTE(APLIB090.PRW) 03/01/2018 17:40:20 line : 609
Called from FWPREEXECUTE(FWPREEXECUTE.PRW) 03/01/2018 17:40:20 line : 82
Called from {||  FWPreExecute('Recibos de Pagamento', 'GPER030()', 1, '07', 'xxxxxxxxxx') }(FWUIMENUL.PRW) 03/01/2018 17:40:20 line : 82
Called from ::TWINDOW:ACTIVATE line : 82
Called from MSAPP:ACTIVATE(FWAPP.PRW) 03/01/2018 17:40:20 line : 682
Called from SIGAADV(APLIB000.PRW) 03/01/2018 17:40:20 line : 58
Called from STATICCALL(APLIB000.PRW) 03/01/2018 17:40:20 line : 58

Ambiente
Protheus - Recursos Humanos - A partir da versão 12.1.17
 

Solução:

A Release Oficial foi expedida e publicada na Central de Downloads.
O pacote pode ser acessado no endereço:

12.1.16: https://suporte.totvs.com/portal/p/10098/download?e=660316 ; 12.1.17: https://suporte.totvs.com/portal/p/10098/download?e=660342 ;

Observação: Caso esteja com o RPO muito desatualizado, além de aplicar o pacote pontual acima, será necessário atualizar também o pacote acumulado da sua versão conforme a base de conhecimento: PSIGABD0086 - Qual o link direto para pesquisar e baixar o pacote acumulado do Portal do Cliente?

Aceitar apenas fontes atualizados. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _