Ocorrência
Feita a parametrização do pagamento via cartão de crédito na modalidade Checkout da Cielo, mas ao realizar um teste de pagamento pelo portal educacional a mensagem abaixo é exibida:
Status da Transação: Erro na criação da transação!
Código de Retorno: ???
Mensagem de Retorno: [Order.Soft.Descriptor] deve conter um valor alfanumérico.
Ambiente
RM – TOTVS Gestão Financeira – Todas as versões.
Causa
O incidente ocorre pelo fato do nome do Serviço associado ao boleto que está sendo pago possuir um espaço (Mensalidade Graduação), por exemplo. A Cielo recebe esta informação, mas não aceita espaço entre as palavras.
Solução
Para solucionar a ocorrência, deve-se acessar o cadastro de Serviços do Totvs Educacional e retirar o espaço do campo SSERVICO.NOME.
Saiba mais
Para mais detalhes sobre esse procedimento, acesse o manual Checkout Cielo.
0 Comentários