FAQs - Suporte técnico

MP - SIGAATF - Variable does not exist CTYPES10

Ocorrência
No módulo Compras, ao tentar realizar a inclusão de um ativo fixo é exibido a mensagem variable does not exist CTYPES10 on AF010ACHV(ATFA010A.PRW)

Esta ocorrência também é exibida no ambiente de Ativo Fixo ao tentar realizar a classificação de um ativo fixo.


Ambiente
Protheus – Ativo Fixo – A partir da versão 12.1.17

Causa

Esse incidente ocorre, pois o sistema não conseguiu verificar a existência das novas validações do cadastro de bens na tabela SN3.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:


1. Acessar o portal do cliente e realizar o download do dicionário completo e diferencial disponibilizado no mês de Janeiro/2018

  • 18-01-12-BRA-DICIONARIOS_COMPL_12_1_17 - Completo
  • 18-01-12-BRA-DICIONARIOS_DIF_12_1_17 - Diferencial

Obs.: Lembrando que em caso de dicionários para outros países, deve-se realizar o download do pais respectivo.

2. Realizar o backup do seu ambiente (dicionário e dados)

3. Excluir os arquivos de log abaixo:

Dentro da pasta system:

mpupdlog.log
mpupdlog.fpt
mpwizard.hlp
mpwizardhlp.lck

Dentro da pasta Appserver:

mpupddistri.tsk


4. Copiar os arquivos para a sua pasta systemload 

5. Realizar a execução do UPDDISTR. (sem a execução deste processo o erro não e corrigido)

6. Será necessário verificar via configurador se o campo N3_TIPO esta com a seguinte validação: "ExistCpo("SX5","G1"+M->N3_TIPO) .And. AF012ATIPO() .And. AF012AAQUI()" Caso não esteja, proceder os passos 2 ao 5 novamente ou realizar a alteração manualmente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _