Tempo aproximado para leitura: 00:00:30 min
Ocorrência
Não está sendo possível excluir pedido no Monitor de Pedidos (pedido-execucao-monitor). A opção Excluir aparece desabilitada.
Ambiente
Framework - Linha Datasul - FRW - Todas as versões
Causas
O fato de a opção Excluir aparecer desabilitada tem como causas:
- o usuário não ser o criador do pedido ou supervisor do RPW;
- o pedido estar com o status em Execução e ainda não ter sido cancelado;
Solução
Verifique se o usuário logado é o usuário que criou o pedido ou o supervisor do RPW. A opção Excluir só estará disponível para estes usuários.
Quando o pedido já está em Execução é necessário primeiro Cancelar o pedido para que a opção Excluir Pedido fique habilitada. No entanto, a opção Cancelar Pedido é uma função que só está disponível no Novo RPW. Ela só fica ativa se o Taksmanager/Automação de Tarefas estiver habilitado no ambiente conforme documentação https://tdn.totvs.com/pages/releaseview.action?pageId=461920564.
0 Comentários