Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - BI - Não será possível executar essa consulta, pois não foi possível aplicar o filtro por usuário ou por perfil


time.png Tempo aproximado para leitura: 02:00:00 min

Ocorrência
Ao rodar a consulta SQL, ou ao utilizar alguma ferramenta de análise que necessita da consulta SQL ocorre o erro: Não será possível executar essa consulta, pois não foi possível aplicar o filtro por usuário ou por perfil. A consulta XXX deverá conter o(s) seguinte(s) campo(s) da tabela XXX



Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - Todas as versões

Causa 
O erro exemplificado acima, ocorre em função do usuário possuir filtro por usuário para a tabela PFUNC. 




Dessa forma, ao executar algum tipo de rotina que executa cálculos através da consultas SQL que estão associadas ao usuário e esta(s) consulta(s) não possuem os campos utilizados pelo filtro, será apresentado o erro.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Edite a consulta que está vinculada ao processo. No exemplo supracitado, estamos utilizando a PFUNC_2, onde consta a seguinte consulta: SELECT CODCOLIGADA, CHAPA, CODSECAO, NOME FROM PFUNC ;



2. Foi necessário editar a consulta para SELECT CODCOLIGADA, CHAPA, CODSECAO, NOME, CODCATEGORIA, CODFUNCAO FROM PFUNC para que o erro fosse sanado.



Saiba mais
Para mais informações acesse:
- Como criar filtro por usuário;
- Como criar filtro por perfil .


 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _