Tempo aproximado para leitura: HH:MM:SS min
Ocorrência
Na tela Monitor Pedido Execução (HTML) - pedido-execucao-monitor, ao detalhar um pedido com status Falha, é informada a mensagem Limite de execução do usuário como Descrição da situação.
Ambiente
Framework - Framework (Linha Datasul) - Menu (MNU) - Versão 12
Causa
A falha na execução do pedido ocorre pois o usuário tentou executar um número de pedidos maior que o limite configurado no cadastro do servidor de aplicação para o Taskmanager.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Identifique quantos pedidos recorrentes do usuário estão com o status Executando. Para isso, na tela Monitor Pedido Execução (HTML) - pedido-execucao-monitor utilize na Busca avançada os filtros Usuário e Situações - Executando;
2. Verifique quantas execuções simultâneas para o usuário estão configuradas no Taskmanager. Para isso, acesse o programa Empresas do Foundation (HTML) - html.companies, vá no ícone de opções dos três pontos e selecione a opção Cadastros Relacionados. Na aba Servidores de aplicação, verifique o valor na coluna Quantidade execuções usuário do servidor Taskmanager utilizado;
3. Será constatado que o número de pedidos enviados pelo usuário ultrapassa o número configurado em Quantidade execuções usuário. Neste caso, o recomendado é aguardar a execução dos pedidos lançados anteriormente para um novo lançamento.
Se os pedidos estiverem travados com o status Executando, leia o artigo no Saiba Mais.
Saiba Mais
Framework - Linha Datasul - FRW - O que fazer quando os pedidos de execução estão ficando presos com o status Executando no Novo RPW - Automação de Tarefas
0 Comentários