Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo Supermercados - API's - Erro de conexão com Devart em APIs .Net Core

relogio_tempo_leitura_2.png Tempo estimado para leitura: 00:02:00


Dúvida
Quando ocorre erro nas autenticações de algumas APIs que utilizam .NET Core.


Ambiente
Varejo Supermercados - API - a partir do Oracle 19.24


Descrição do problema
Após a atualização do Oracle para a versão 19.24 ou superior, passou a ocorrer falha na conexão com o Devart DotConnect quando utilizado com direct=true. O problema está relacionado à configuração dos parâmetros de criptografia no arquivo sql.net do Oracle e afeta conexões diretas quando certos parâmetros estão definidos como REQUIRED.

Mensagem de erro exibida (verificar nos eventos do Windows)

Tnf.Drivers.Devart.DevartDotConnectException: Error trying open a connection using Devart DotConnect (Action: Validate License) ---> System.InvalidOperationException: Cannot obtain Oracle Client information from registry. Make sure that Oracle Client Software is installed and that the bitness of your application (x64) matches the bitness of your Oracle Client, or use the Direct mode of connecting to a server.

Erros visuais relacionados:

Acesso direto à API pelo navegador:

Inspeção da página na aba 'Console':

Abertura da aplicação:

Causa
O erro é provocado por uma incompatibilidade entre as versões recentes do Oracle (≥ 19.24) e versões anteriores do Devart DotConnect ao utilizar o modo Direct com determinados parâmetros de criptografia exigidos (SQLNET.ENCRYPTION_SERVER, SQLNET.CRYPTO_CHECKSUM_SERVER, SQLNET.ENCRYPTION_CLIENT, SQLNET.CRYPTO_CHECKSUM_CLIENT).

 

Soluções paliativas (temporárias)

  1. Remover o parâmetro direct=true da string de conexão das APIs. (Não recomendado)
    • Observação: sem o modo Direct, a aplicação depende do Oracle Client instalado no servidor, que deve ser compatível com a arquitetura de 64 bits.
    • Esta solução é temporária, pois futuras atualizações do ERP podem reintroduzir o parâmetro direct=true.
  2. Alterar os parâmetros no arquivo sql.net do Oracle.
    • Solicite ao DBA do cliente que modifique os parâmetros de REQUIRED para ACCEPTED nos seguintes locais:

      • GRID_HOME\network\admin
      • ORACLE_HOME\network\admin

      Dentro destes diretórios, adicione ou altere os seguintes parâmetros (caso estejam definidos como REQUIRED, substitua por ACCEPTED), conforme o exemplo:


      SQLNET.ENCRYPTION_SERVER = ACCEPTED
      SQLNET.CRYPTO_CHECKSUM_SERVER = ACCEPTED

      SQLNET.ENCRYPTION_CLIENT = ACCEPTED
      SQLNET.CRYPTO_CHECKSUM_CLIENT = ACCEPTED

    • Recomenda-se reiniciar o listener do Oracle após as alterações, pois as conexões poderão ser temporariamente interrompidas.

Referência:

Release Notes Devart DotConnect for Oracle – versão 10.3.104

 

Correção definitiva

O problema foi corrigido a partir da versão 10.3.104 do Devart.
A versão do framework TNF 8.1.1.18802 já inclui esta atualização.
➡️ Solução recomendada: Atualizar o framework TNF do projeto. Esta atualização atualizará automaticamente a versão do Devart, eliminando o erro.

Alguns projetos da versão 25.07 estão sendo atualizados, porém somente a partir da versão 26.01 todos os projetos estarão atualizados e livres deste erro.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _