Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

CROSS Segmentos - TOTVS Backoffice Linha Protheus - FIS - Erro argument #0 error, expected A->U, function asize on TOTVS.PROTHEUS.BACKOFFICE.FISCAL ao gerar nota com impostos calculados pelo Configurador de Tributos

time.png Tempo aproximado para leitura: 00:10 min

Ocorrência
Ao gerar uma nota fiscal em que os impostos são calculados pelo Configurador de Tributos, está sendo registrado o seguinte error.log:

argument #0 error, expected A->U,  function asize on TOTVS.PROTHEUS.BACKOFFICE.FISCAL.ADDITIONALDATA.TCADDITIONALDATA:GETADDITIONALDATAIDSFROMMATXFIS(BACKOFFICE.FISCAL.TAXCONFIGURATOR.ADDITIONALDATA.CLASS.TLPP)

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - FIS - A partir da versão 12.1.2310

Causa 
Esse erro ocorre devido a uma inconsistência interna relacionada ao cálculo tributário com o uso do Configurador de Tributos nas versões impactadas do Protheus.

Solução
Para corrigir essa situação, é necessário aplicar os pacotes de atualização disponibilizados conforme a versão do seu ambiente Protheus.

Segue abaixo a relação das versões e seus respectivos links de atualização:

Versão Protheus Link para atualização
12.1.2210 Download
12.1.2310 Download
12.1.2410 Download
12.1.2510 Download

 

⚠️ Importante: Após aplicar o pacote, certifique-se de compilar os fontes atualizados, aplicar dicionários e reiniciar os serviços do Protheus.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _