Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Ocorreu um erro ao criar/reenviar o comunicado. - String or binary data would be truncated

time.png Tempo aproximado para leitura: 00:02:35 min

Ocorrência
Ao tentar enviar um comunicado é apresentado a mensagem de erro " Ocorreu um erro ao criar/reenviar o comunicado. - String or binary data would be truncated ".

Ambiente
TOTVS RH - TOTVS RH (Linha RM) – Meu RH – A partir da versão 12.1.2502.

Causa
Esse incidente ocorre porque a quantidade de caracteres informada em algum campo do comunicado ultrapassa o tamanho máximo definido na estrutura da tabela no banco de dados. Ou seja, está sendo inserido uma String (texto) maior do que o permitido para aquele campo.
 
Motivos mais comuns:
 

  • Título ou conteúdo do comunicado com excesso de caracteres.
  • Campos internos (como nome da empresa, departamento, função etc.) cujo conteúdo somado ultrapassa o limite.
  • Erros em campos configuráveis pela TOTVS, geralmente causados por customizações que não ajustaram corretamente os limites de tamanho.


Solução
Verifique se algum dos campos preenchidos ultrapassa o limite de caracteres. Neste exemplo, como o comunicado será enviado para todos os cargos, não é necessário selecionar todos na opção Função, pois já foram definidos a filial e o departamento. Os filtros devem ser utilizados apenas quando houver necessidade de restringir a comunicação a funcionários específicos.

 

Saiba mais:
Comunicados para o RH

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _