Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - SPEDFISCAL Erro na inclusão TR2: TOP Error - 19 - Invalid bind parameter size 4096

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar gerar o SPEDFISCAL com o Bloco H em ambiente PostgreSQL, o sistema retorna "Erro na inclusão TR2: TOP Error - 19 - Invalid bind parameter size 4096"

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Protheus Release 12.1.33 ou Superior.

Causa 
Este erro pode ocorrer devido a alguns fatores, como por exemplo, atualizações, pontos de entrada e customizações e/ou configuração incorreta do ODBC, abaixo estaremos informando pontos para a avaliação e correção.

Solução
 

  1. Banco de dados com versão não homologada;

    Durante nossa avaliação em alguns ambientes verificamos que o erro ocorria para versões PostgreSQL não homologadas para uso DBAcess, para esses casos a recomendação é efetuar a utilização do banco uma versão homologada para a correta comunição entre o Protheus e o Banco de Dados, segue abaixo uma documentação com os Bancos e versões homologados
    Banco de dados e versões Homologadas
     
  2. Versões inferiores à 17 do Driver de ODBC para a plataforma Windows.
    Conforme informado na documentação acima, há um bug conhecido e relatado à comunidade do PostgreSQL na versão 16 do driver de ODBC para a plataforma Windows. Também notamos casos com versões inferiores à 16, por exemplo a 13, onde ocorria o erro. Por isso, recomendamos a atualização do driver para a versão 17.00.0003 ou superior.
     
  3. Configuração indevida no ODBC:
    Verificamos que, em ambientes que utilizam banco de dados PostgreSQL, é necessária maior atenção na configuração do ODBC. Neste caso, verifique como está a configuração do seu ODBC e se ela está conforme a documentação abaixo:

    - Como criar uma fonte de dados ODBC para uso com PostgreSQL no Windows
    - Como criar uma fonte de dados ODBC para uso com PostgreSQL no LINUX
     
  4. Fontes e artefatos desatualizados: 
    Verificamos também que alguns casos foram corrigidos após a atualização dos fontes e artefatos, neste caso por gentileza, verifique se seu ambiente está devidamente atualizado, caso não efetue um teste em ambiente de Homologação com as atualizações a seguir:
     - Acumulado BackOffice conforme sua versão

    - LIB AtualLogo Guará | Harpia
    - Appserver
    - Smartclient - Lobo Guará | Harpia
    - DBAccess
    - Central de Atualizações
     
  5. E se mesmo assim persistir?
    Caso ainda persistir, compreendemos que se faz necessário avaliar pontualmente seu caso. Sendo assim, por favor, nos envie:

    - Erro.log gerado completo;
    - Banco e versão que está utilizando;
    - Versão do Drive do ODBC está utilizando;
    - Print da configuração do seu ODBC;
    - Video demonstrando os parâmetros utilizados na rotina;
    - Inspetor de Objetos análise dos fontes envolvidos;
     

Saiba mais:

Clique aqui e saiba mais sobre Legais/Fiscais no Estoque.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _