Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro "A entidade do tipo Report não foi encontrada" ao acessar relatório do Smart View pelo Datasul

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao acessar algum relatório do Smart View pelo Datasul usando um usuário que não seja o usuário administrador do Smart View, é apresentado o erro A entidade do tipo Report com id XXX-XXX-XXX-XXX não foi encontrada.

Ambiente
Framework - Framework (Linha Datasul) - Smart View (SVW) - Todas as versões

Causa 
Esse erro ocorre quando o usuário está tentando acessar o relatório e não possui permissão de acesso aos dados do mesmo.

Solução
Para corrigir este erro, é necessário compartilhar o layout do relatório com um grupo de segurança que o usuário faça parte:
1- Acessar o Datasul com o usuário administrador do Smart View
2- No programa html.fwk-smartview-layout (Importação Layout SmartView) localizar o layout do relatório desejado

Ex: layout rpUsuarMestre



3- Compartilhar o layout com os grupos de segurança desejados.



Após o compartilhamento com o grupo de segurança, todos os usuários que fazem parte do grupo de segurança poderão acessar o relatório.

Saiba mais
Documentações Smart View 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _