Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MC - CST - Erro de Truncamento em Campos de Centro de Custo (DE_CCUSTO_DE e DE_CCUSTO_PARA)

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao tentar inserir ou atualizar dados em uma tabela, é apresentado o erro:
String or binary data would be truncated.

Esse erro ocorre quando o conteúdo a ser inserido excede o tamanho máximo permitido para a coluna no banco de dados.

Identificou-se que, em ocorrências anteriores, os campos DE_CCUSTO_DE e DE_CCUSTO_PARA, originalmente definidos com tamanho 30, podem causar esse erro.

Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Custos Agrícola- Versão 12

Causa 
O erro acontece porque os campos DE_CCUSTO_DE e DE_CCUSTO_PARA foram definidos originalmente com tamanho 30 caracteres.
Quando a aplicação tenta inserir ou atualizar dados maiores que esse limite, o banco de dados não consegue armazenar e retorna o erro de truncamento.

Solução
Para solucionar essa ocorrência, realize os ajustes do tamanho das colunas para 60 caracteres, evitando que dados maiores sejam rejeitados.

SQL Server:

ALTER TABLE PLC_RATORDEMPRD 
ALTER COLUMN DE_CCUSTO_DE VARCHAR(60);

ALTER TABLE PLC_RATORDEMPRD 
ALTER COLUMN DE_CCUSTO_PARA VARCHAR(60);

Oracle:

ALTER TABLE PLC_RATORDEMPRD 
MODIFY (DE_CCUSTO_DE VARCHAR2(60));

ALTER TABLE PLC_RATORDEMPRD 
MODIFY (DE_CCUSTO_PARA VARCHAR2(60));
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _