Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA010 - Ao tentar excluir um produto ocorre - Alias does not exist TNF

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Durante a criação de um produto, foi identificado que não há vínculo ou utilização do módulo 35 – Medicina e Segurança do Trabalho, no qual a tabela TNF é alimentada pela rotina Funcionário x EPI (MDTA695).
Ao acessar a rotina, ocorre o seguinte erro:

TNF: TOP Error -19 - not found for table [TNF]. (From tISAMFile::CreateIndex)  
(PREVIOUS ERROR: Alias does not exist: TNF) on TABLECREATE(APLIB200.PRW)

Ambiente 
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

 

Causa 
O problema ocorre devido a indices incorretos na tabela TNF

 

Solução

Valide se os índices da tabela TNF estão padronizados conforme a tabela SIX.

  • A quantidade e a ordem dos índices devem ser idênticas conforme imagens a seguir:

    TNFINDICE.png

    TNFINDICE2.png

    TNFINDICE3.png

Caso a tabela TNF não apresente os mesmos índices definidos na SIX:

  • Será necessário realizar manutenção para recriação dos índices.
  • Para isso, envolva o time técnico responsável e proceda da seguinte forma:
    • Se não houver dados na tabela TNF: realizar o drop da tabela diretamente.
    • Se houver dados: efetuar previamente um backup completo antes do drop sempre.

Após o drop:

  • Acesse novamente a rotina MDTA695 para que a tabela TNF seja recriada automaticamente.
  • Valide se os índices foram recriados corretamente dentro da própria tabela, de acordo a quantidade de indices existentes na SIX

 

Observação

  • Em anexo, encontra-se a tabela SIX filtrada pela TNF, para validação técnica pelo seu time de infraestrutura, caso necessário.
  • Os índices foram coletados em 12/09/2025. Ressalta-se que podem sofrer alterações em versões futuras; portanto, recomenda-se sempre validar as atualizações mais recentes do produto.

 

Saiba mais:

Clique aqui para mais informações sobre a MATA010

Clique aqui e veja mais artigos sobre Cadastros e Configurações no Estoque

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Configuração de envio Messenger para ID de eventos do Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _