Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Loop ao realizar login no Meu RH integrado com o Azure

time.png Tempo aproximado para leitura: 00:02:19 min

Ocorrência
Ao realizar o login integrado com o Azure no Meu RH, ocorre um loop de autenticação, no qual a tela de login é reaberta repetidamente após a inserção das credenciais.


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas as versões

Causa 
O problema ocorre devido à configuração de cabeçalhos adicionais no IIS, que bloqueiam a comunicação necessária entre o Meu RH e o Microsoft Azure durante o processo de autenticação.

Cabeçalhos que causam o erro:

* Cross-Origin-Opener-Policy
* Cross-Origin-Resource-Policy
* Strict-Transport-Security
* Referrer Policy

Solução
Para corrigir o erro de loop no login, é necessário remover esses cabeçalhos dos sites FrameHTML e Default Web Site no IIS.

1. No servidor do Portal, abra o IIS (Internet Information Services).
2. Selecione o Default Web Site > Cabeçalhos de respostas.


3. Remova os cabeçalhos que impedem a comunicação.

4. Faça o mesmo processo de remoção no site FrameHTML

5. Reinicie todos os serviços Host e, em seguida, reinicie o IIS para aplicar as alterações.

 

Saiba mais

RH - RM - Meu RH - Integração OAuth2, Meu RH X Azure


 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _