Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

PDV - SUP - Falha na conexão com o banco de dados - Error while tryng to retrieve text for error - ORA-01804

time.pngTempo aproximado para leitura: 00:02:00 min

 

Ocorrência
No PDV – SUP, ao tentar instalar o Monitor de PDVs, é exibido erro relacionado à configuração do Oracle no registro do Windows, impedindo a conclusão da instalação.



Ambiente
TOTVS Distribuição Linha Winthor - 20 - PDV - Supermercados -  A partir da versão 30
 

Causa:
O erro ocorre porque a chave de registro do Oracle (NLS_LANG) está configurada de forma incorreta, o que gera incompatibilidade durante a instalação do Monitor de PDVs.

 

Solução
Para solucionar essa ocorrência, siga os passos abaixo:

  1. Clique no Menu Iniciar e digite regedit para abrir o Editor de Registro do Windows.

  2. Localize a chave de acordo com a versão do Oracle instalada:

    • Oracle 19

      • Win 64 bits → HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE\KEY_OraClient19Home1_32bit

      • Win 32 bits → HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient19Home1_32bit

    • Oracle 11

      • Win 64 bits → HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE\KEY_OraClient11g_home1

      • Win 32 bits → HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient11g_home1

  3. Altere o valor da chave NLS_LANG para: AMERICAN_AMERICA.WE8ISO8859P1

  4. Logo após a alteração, responda a mensagem do instalador clicando em No e aguarde a remoção dos arquivos iniciais da instalação.

  5. Abra o Painel de Controle do Windows e remova a instalação do Monitor de PDVs.

  6. Reinicie o computador.

  7. Prossiga com uma nova instalação do Monitor de PDVs.

 

 


 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _