Tempo aproximado para leitura: 00:02:00 min
Ocorrência
No PDV – SUP, ao tentar instalar o Monitor de PDVs, é exibido erro relacionado à configuração do Oracle no registro do Windows, impedindo a conclusão da instalação.
Ambiente
TOTVS Distribuição Linha Winthor - 20 - PDV - Supermercados - A partir da versão 30
Causa:
O erro ocorre porque a chave de registro do Oracle (NLS_LANG) está configurada de forma incorreta, o que gera incompatibilidade durante a instalação do Monitor de PDVs.
Solução
Para solucionar essa ocorrência, siga os passos abaixo:
Clique no Menu Iniciar e digite
regeditpara abrir o Editor de Registro do Windows.Localize a chave de acordo com a versão do Oracle instalada:
Oracle 19
Win 64 bits →
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE\KEY_OraClient19Home1_32bitWin 32 bits →
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient19Home1_32bit
Oracle 11
Win 64 bits →
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE\KEY_OraClient11g_home1Win 32 bits →
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient11g_home1
Altere o valor da chave NLS_LANG para:
AMERICAN_AMERICA.WE8ISO8859P1Logo após a alteração, responda a mensagem do instalador clicando em No e aguarde a remoção dos arquivos iniciais da instalação.
Abra o Painel de Controle do Windows e remova a instalação do Monitor de PDVs.
Reinicie o computador.
Prossiga com uma nova instalação do Monitor de PDVs.
0 Comentários