Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - SIGAFAT - A chave CheckSpecialKey em seu ambiente está desligada, você deve liga-la para seu uso da seção [GENERAL]

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
No módulo de Faturamento, ao tentar preparar o documento de saída e selecionar a numeração da nota, ocorre o seguinte erro:
"A chave CheckSpecialKey em seu ambiente está desligada. Você deve ativá-la para utilizar esta funcionalidade na seção [GENERAL], em BACKOFFICE.STOCK.NEWPROXNUM.VALIDSPECIAKEY."
Esse incidente interrompe a execução da aplicação.

Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - A partir da release 12.1.2410.

Causa 
Esse incidente ocorre porque, na parametrização do Appserver, na seção [GENERAL], a chave CHECKSPECIALKEY está definida com o valor "0".


Solução
Está sendo implementada na LIB uma validação de Controle de Numeração, que tem como objetivo verificar se o ambiente está corretamente configurado com a chave SpecialKey.

Caso a configuração não esteja adequada, o sistema emitirá uma notificação informando a necessidade de ativação da chave e interromperá a operação em andamento. Essa medida visa garantir a integridade dos dados e prevenir eventuais inconsistências futuras.

Enquanto essa validação não estiver completamente implementada na LIB, a ausência da chave SpecialKey ou a definição da chave CheckSpecialKey com o valor 0 poderá resultar na interrupção da execução da aplicação, com a geração do seguinte erro no error.log:

A chave CheckSpecialKey em seu ambiente está desligada. Você deve ativá-la para seu uso na seção [GENERAL].”

Para garantir o correto funcionamento do sistema até a conclusão da implementação, recomenda-se configurar a chave CHECKSPECIALKEY com o valor 1, ou simplesmente removê-la da seção [GENERAL] no arquivo de configuração do Appserver.

Saiba mais:

2024 - 31/10 Parâmetro MV_DOCSEQ

DT Proxnum | Validação SpecialKey

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _