Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Linha Backoffice Protheus - Financeiro - Contas a Pagar - FINA420 - Não gera linha final do arquivo de remessa

time.png Tempo aproximado para leitura: 00:10:00 min

Ocorrência
No módulo Financeiro, ao gerar o arquivo TXT, a rotina não está fazendo a quebra de linha na última linha do trailler do arquivo, causando incosistencia no validador do banco que não consegui identificar o final do arquivo.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - Todas as versões

Causa 
Esse incidente ocorre, pois o campo EE_FIMLIN não está ativado para uso dentro da rotina FINA130 - Parametros de Bancos

Solução
Acesse o SIGACFG e siga o caminho:
Base de Dados >> Dicionário de Dados >> Tabela SEE.

Em seguida:

  • Localize o campo EE_FIMLIN;

  • Habilite a opção "Usado";

  • Salve o dicionário;

  • Defina o campo com o valor 1 - Sim.

Após essa configuração, será gerada a linha final de arquivo.

O objetivo desta rotina é atender tanto à necessidade que alguns bancos têm de que sejam incluídos os caracteres finalizadores de linha na gravação do registro Trailer no CNAB modelo 1/2 como para aqueles bancos que não exigem esses caracteres.
Para atender às exigências de todos os bancos, deve-se habilitar ou criar o campo "Final linha" (EE_FIMLIN) na tabela SEE (Comunicação remota), conforme descrição a seguir.
 

Tabela

SEE

Campo

EE_FIMLIN

Título

Final de linha

Validação

Pertence ( 12 )

Opções

1 = Sim (padrão do sistema)

Indica se devem-se incluir os caracteres de final de linha (Chr(13)+(Chr(10)) ao gravar o registro Trailler no Cnab modelo 1/2, visto que alguns bancos invalidam o tamanho do registro quando ele não contém os finalizadores de linha.

2 = Não


Saiba mais
Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - Principais configurações e dúvidas para uso do CNAB

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _