Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - NFE - Falha de schema no XML da Nfe com os novos tributos da Reforma Tributária

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao validar o XML da NFe - Nota Fiscal Eletrônica para atender à RT - Reforma Tributária com o envio das tags dos novos tributos, apresenta Falha de Schema.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFe) - A partir da versão 12.1.2411.13

Causa 
O problema ocorre devido ao Produto TSS desatualizado.

Solução

Atualizar o TSS.

Caso não esteja ainda na release 12.1.2410, será necessário fazer a migração para essa versão.

Abaixo os artigos em sequência, com os procedimentos para migrar o TSS para a versão 12.1.2410:

  1. Realizar  este procedimento com os serviços do TSS e DBAccess parados.

  2. Baixar o instalador: TOTVS SERVICE SOA (TSS) - RELEASE 12.1.2410 - WINDOWS

  3. Efetuar a instalação.

  4. Informar corretamente os dados no instalador, para que seja criado o novo arquivo de inicialização, atualizado com novos parâmetros.

  5. Deve ser apontado para o mesmo banco de dados.

Na sequencia, será necessário efetuar a atualização do produto. Lembrando que o TSS é expedido em Releases, como é feito com o produto Datasul, e após a instalação de nova versão do produto, é preciso efetuar a sua atualização.

E caso já esteja na versão 12.1.2410 também será necessário efetuar a atualização abaixo:

Segue abaixo os artigos, em sequência, com os procedimentos de atualização do TSS:

Repositório - MP - TSS - Atualização do Repositório (RPO) do TSS
Binário - MP - TSS - Atualização do Appserver (binário) do TSS
Schemas - TSS - Atualização dos SCHEMAS

Segue link para download do DBAccess atualizado: TOTVS DBACCESS WINDOWS X64 - BUILD 24.1.0.6

Após descompactar e atualizar o DBAccess - instalação nova, copiar o conteúdo da pasta CLIENT do DBAccess para dentro do diretório APPSERVER do TSS

Após a atualização desses arquivos, o serviço do TSS pode ser inicializado novamente.

Importante
É necessário revisar o ambiente de instalação do TSS, confirmando se ele ainda é homologado para os produtos Application Server e DBAccess, no qual são a base para funcionamento do TSS.

Application Server
DBAccess - Sistemas Operacionais
DBAccess - Bancos de Dados

Essa revisão é importante porque a TOTVS deixa de homologar seus produtos quando o Sistema Operacional ou Banco de Dados é descontinuado por seus fornecedores. E quando o produto está em um ambiente não homologado, temos limitações no suporte técnico.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _