Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - NFC - Não é possível alterar a quantidade C8_QUANT no Novo Fluxo de Compra.


time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Ao realizar a Atualização da Cotação no Novo Fluxo de Compra, o sistema não permite alterar o valor do campo Quantidade da linha do item.



Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS COMPRAS - A partir da Versão 12.1.2410

Causa 
Independentemente da configuração atribuída ao campo C8_QUANT no SIGACFG (seja para visualização ou alteração), não será possível modificar seu conteúdo.

Isso ocorre pois esse campo C8_QUANT tem por função carregar a quantidade original da cotação. A quantidade que veio da solicitação na qual a cotação foi gerada.

Solução
Sendo assim, caso a quantidade a ser cotada for menor que o conteúdo do C8_QUANT, deverá preencher essa informação no campo C8_QTDISP. Caso a quantidade seja maior que a quantidade do campo C8_QUANT, deverá ser incluída uma nova solicitação de compra com a nova quantidade correta.
 
Por padrão, o campo Quantidade a ser adquirida já é preenchido com o mesmo valor do saldo disponível. O comprador - nesse campo - pode inserir um valor maior que zero e igual ou menor que o saldo disponível:
 
 

Valor Saldo Valor Quantidade a ser adquirida Resultado
30 30 Ação será realizada, pois a quantidade inserida está de acordo com o saldo existente (quantidade a ser adquirida igual a saldo disponível).
30 31 O usuário será alertado, informando que a quantidade inserida é maior que o saldo disponível. Automaticamente, o sistema irá preencher o campo Quantidade a ser adquirida com o valor 30 (valor do saldo). Deverá incluir nova Solicitação de Compras e Cotação.
30 15 Ação será realizada, pois a quantidade inserida está de acordo com o saldo existente (quantidade a ser adquirida menor que o saldo disponível).
30 0 O usuário será alertado, informando que a quantidade inserida deve ser maior que zero. Automaticamente, o sistema irá preencher o campo Quantidade a ser adquirida com o valor 30 (valor do saldo).
30 -5 O usuário será alertado, informando que a quantidade inserida deve ser maior que zero. Automaticamente, o sistema irá preencher o campo Quantidade a ser adquirida com o valor 30 (valor do saldo).

 
Novo Fluxo de Compras: Guia de Referência - Gestão de Compras - P12

 

SAIBA MAIS EM :

Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - Novo Fluxo de Compras - NFC (PGCA010)

PÁGINA CENTRALIZADORA COMPRAS

Mais Artigos Materiais - Compras (SIGACOM)
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _