Tempo aproximado para leitura: 00:05:00 min
Ocorrência
Ao acessar a rotina TECA300 - Chamado Técnico, apresenta o erro HELP INITERR.
Ambiente
Prestadores de Serviços - SIGATEC - A partir da release P12.1.2410.
Causa
Esse incidente ocorre porque a configuração da função de validação do inicializador padrão do campo AB1_NOMCLI está incorreta.
Solução
Para solucionar essa ocorrência, siga os passos abaixo:
Acesse o módulo Configurador (SIGACFG).
Entre na base de dados e navegue até Base de Dados > Dicionário > Base de Dados.Acesse a opção Dicionário de Dados e faça uma busca pela tabela AB1.
No campo AB1_NOMCLI, verifique a configuração do campo INIC. Padrão, que deve estar semelhante a:
IF(!INCLUI,ALLTRIM(POSICIONE("SA1",1,XFILIAL("SA1")+FWfldGet(AB1_CODCLI)+FwfldGet(AB1->AB1_LOJA),"A1_NOME")),"")Substitua o conteúdo do campo INIC. Padrão pelo seguinte código:
IF(!INCLUI,ALLTRIM(POSICIONE("SA1",1,XFILIAL("SA1")+AB1->AB1_CODCLI+AB1->AB1_LOJA,"A1_NOME")),"")Salve a alteração na base de dados para que ela tenha efeito.
Saiba mais: GS0117 Erro Inicializador padrão AB1_NOMCLI
0 Comentários