O artigo aborda um problema ao tentar movimentar produtos com controle de lote no TOTVS Backoffice (Linha Protheus), onde o sistema apresenta o HELP F4LOTE. Isso ocorre quando não há saldo de lote disponível para a movimentação. A solução envolve verificar o saldo atual do produto, confirmar a ativação do parâmetro MV_RASTRO, garantir que não há desbalanceamento de saldos, checar se o produto pertence a terceiros e se o lote está vencido. Caso o problema persista, recomenda-se testar em um ambiente atualizado e desativar customizações.
Tempo aproximado para leitura: 00:02:00 min
Dúvida
Ao tentar efetuar uma movimentação de saida/requisição de um produto que tem controle de lote, o HELP F4LOTE é apresentado em tela.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Quando o HELP é acionado, significa que o sistema não achou relação do saldo do lote do produto para a movimentação. Assim, ao tentar requisitar saldo do produto em algumas rotinas o sistema apresenta o help F4LOTE.
Solução
Verifique as possibilidades de solução dependendo do seu cenário:
1. Verifique se o Saldo ATUAL do Produto, existe de fato no local o qual voce quer requisitar a quantia de movimentação (Como descobrir a origem dos saldos na consulta com comando [F4]);
2. Confira de fato se o parametro MV_RASTRO esteja ativo no ambiente, bem como no cadastro do produto, o campo "Rastro B1_RASTRO" esteja configurado para o controle devido de L = Lote.
3. Certifique que o produto não possua algum desbalanceamento de saldos, apartir da geração do relaotiro MATR282 Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATR282 - Parametrização para validar divergência de saldos SB2 x SB8 x SBF
4. Valide de fato, se não foi efetuada alguma "Manutenção no banco" para os registros de movimentação desse item, como SD3/SD5/SB8.
5. Verifique se o saldo do produto pertence a Terceiros (É possível requisitar ou consumir Saldo de Terceiro)
6. Verifique se o lote esteja vencido (Movimentar produto com Lote Vencido)
Caso após as verificações o problema persista, avalie:
1. Interferência de incompatibilidade de fontes (necessário testar em ambiente atualizado)
2. Interferência de customizações (necessário testar desativando as customizações do ambiente através dos 3 métodos indicados nesta documentação, impreterivelmente).
Sobre o controle de lotes no FATURAMENTO:
Uso de Lote, Endereçamento e Serie no Faturamento (SIGAFAT)
Saiba mais:
Clique aqui e veja mais artigos sobre Movimentações no Estoque
0 Comentários