Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Falha na atualização de dados ao usar botões de navegação em widget com dataset parcialmente carregado

⏱️Tempo aproximado para leitura: 00:03:15 min

Ocorrência
Ao clicar nos botões de próximo ou anterior de uma widget que utiliza um campo filter conectado a um dataset, os dados não são atualizados na tela.

Ambiente
TOTVS Fluig Plataforma - Desenvolvimento - Todas as versões

Causa
Esse incidente ocorre, pois no dataset utilizado não foi feito a implementação da funcionalidade de paginação Portanto, essa funcionalidade deve ser desenvolvida para que a navegação funcione corretamente.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Valide na Widget utilizada se o desenvolvimento feito está correto.
  2. Acesse a documentação do Style Guide e siga as instruções para garantir que o campo filter e os botões de navegação estejam corretamente integrados; 
    https://style.fluig.com/javascript.html#fluig-datatable
  3. Exemplo do arquivo em javascript:

     

    var filterDataset = SuperWidget.extend({
        mode: null,
    
        init: function () {
        	var settings = {
    		    source: {
    		        url: '/dataset/api/v2/dataset-handle/search?datasetId=colleague&',
    		        contentType: 'application/json',
    		        root: 'values',
    		        pattern: '',
    		        limit: 30,
    		        offset: 0,
    		        patternKey: 'pattern',
    		        limitkey: 'limit',
    		        offsetKey: 'offset'
    		    },
    		    displayKey: 'login',
    		    multiSelect: false,
    		    style: {
    		        autocompleteTagClass: 'tag-gray',
    		        tableSelectedLineClass: 'info'
    		    },
    		    table: {
    		        header: [
    		            {
    		                'title': 'login',
    		                'size': 'col-xs-3'
    		            },
    		            {
    		                'title': 'Name',
    		                'size': 'col-xs-9',
    		                'dataorder': 'name',
    		                'standard': true
    		            }
    		        ],
    		        renderContent: ['login', 'colleagueName']
    		    }
    		};
    		var filter = FLUIGC.filter('#filter-user', settings);
        },
    
        bindings: {
            local: {
                
            }
        }
    });
  4. Teste a funcionalidade após a implementação para garantir que a navegação está realizando as atualizações esperadas na tela.

Saiba mais

  1. Documentação do Style Guide;
  2. Arquivo .war de exemplo para implementação
     
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _