Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro – PIMS IND – MI – Table does not exist ORA-00942: table or view does not exist

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
No módulo Controle Manutenção Industrial - MI, ao tentar executar qualquer Script utilizando Utilitários > Comando SQL, por mais simples que seja com as tabelas do próprio MI, apresenta erro de Tabela não existente ou não encontrada.

PROMI.png

Ambiente
TOTVS Agro – TOTVS Agro – Bioenergia – Controle Manutenção Industrial - MI – Versão 12

Causa 
Esse incidente ocorre, pois quando é executado qualquer Script utilizando Utilitários > Comando SQL, aparece uma mensagem de erro na tela.

Solução
Identificamos que o erro no processo industrial estava relacionado à ausência da tabela PM_RESTR_TABELAS. Após a inclusão da tabela, a aplicação passou a funcionar normalmente.

Segue o Script abaixo:

-- Create table
create table PRXIND.PM_RESTR_TABELAS
(
cd_tabela VARCHAR2(30) not null,
rowversion NUMBER(5)
)
tablespace PIMS_DATA
pctfree 10
initrans 1
maxtrans 255
storage
(
initial 64K
next 1M
minextents 1
maxextents unlimited
);
-- Create/Recreate primary, unique and foreign key constraints
alter table PRXIND.PM_RESTR_TABELAS
add constraint PM_RESTR_TABELAS_PK primary key (CD_TABELA)
using index
tablespace PIMS_INDX
pctfree 10
initrans 2
maxtrans 255
storage
(
initial 64K
next 1M
minextents 1
maxextents unlimited
);
-- Grant/Revoke object privileges
grant select, insert, update, delete on PRXIND.PM_RESTR_TABELAS to NEWMI;
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _