Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Como solucionar erro de "Rota não encontrada" ao incluir AD via API

⏱️Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Durante a integração entre Logix e TOTVS Fluig via API, a tentativa de inclusão de um AD retorna o erro: "Requisição REST não executada. Rota não encontrada para o método e parâmetros informados (InsertAd)".

Ambiente
TOTVS Fluig Plataforma -  Desenvolvimento sobre a Plataforma - Todas as versões

Causa
Esse incidente ocorre, pois a chamada da API está sendo feita de forma inadequada, especificamente utilizando o método GET em vez do método POST, que é o apropriado para inclusão de dados.

Solução
Essa API é do tipo POST. No navegador você somente vai conferir se o serviço REST está ativo, para isso você deve acessar o seguinte endereço: http://suaURL/rest.

O consumo dos métodos não deve ser realizado pelo navegador, os testes precisam ser realizados via aplicativo POSTMAN, segue em anexo (image.png) exemplo.

Note que é necessário enviar um JSON com os dados para inserção da AD (Logix), para isso verifique a seguinte documentação: DMANFINLGX-22015 DT API AD/AP - API para criação de AD/AP.

No TOTVS Fluig, para testes de execução, o TOTVS Fluig suporta apenas o tipo GET nesta tela aqui.

Por isso ele pode retornar erro, pois no caso do POST precisa passar os parâmetros que a API pede.

Mas para utilizar no Dataset você pode sim passar o método do tipo POST. Lembre-se de passar a autenticação no cadastro do serviço em Painel de controle > Serviços.

Para isso, você precisa passar o método POST dentro do seu desenvolvimento. No caso do Dataset, você pode usar o modelo deste material e adaptar para o serviço que está utilizando: Chamada via JavaScript.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _