Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig – Plataforma – FDN – Erro ORA-1205 quando inicia o TOTVS Fluig

⏱️Tempo aproximado para leitura: 00:02:30 min

Ocorrência
Ao tentar acessar a aplicação TOTVS Fluig, é exibida a mensagem de erro 404, indicando que o recurso solicitado não foi encontrado. O log do sistema apresenta o seguinte trecho de erro:

2021-08-11 16:51:37,773 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.OnePool] (Thread-179) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: IJ031084: Unable to create connection
Caused by: java.sql.SQLException: Listener refused the connection with the following error: ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

Ambiente
TOTVS Fluig - Instalação - A partir da versão 1.6.0

Causa
Esse incidente ocorre, pois o TOTVS Fluig não está conseguindo encontrar o recurso solicitado, possivelmente devido a configurações incorretas no arquivo domain.xml ou problemas com a conexão ao banco de dados que impede o servidor de responder a requisições.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Verifique o arquivo de configuração domain.xml localizado em <instalação>/appserver/domain/configuration/.
  2. No arquivo domain.xml, procure pelas tags AppDS, FluigDS e FluigDSRO. Os campos que devem ser verificados e, se necessário, ajustados são:
    • url: Verifique se a URL apontando para o banco de dados está correta, especialmente o SID.
    • user-name: Confirme se o usuário está correto.
    • password: Verifique se a senha está correta.
  3. Certifique-se de que o serviço do Oracle Database está em execução e que o SID (identificador do serviço) está conhecido pelo listener.
  4. Após verificar e corrigir as configurações, reinicie o serviço do Fluig para aplicar as alterações.
  5. Tente acessar novamente a aplicação Fluig após completar os ajustes. Se o problema persistir, consulte os logs do servidor em <instalação>/appserver/domain/log/ para informações adicionais sobre o erro.
  6. Para mais informações sobre o erro ORA-12505, consulte os links abaixo:
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _