Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - Portal do cliente - Não foi possível baixar a Danfe e XML

time.png Tempo aproximado para leitura: 00:08:00 min
 

Ocorrência


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - A partir da release 12.1.33

 

Causa
Caso as premissas estabelecidas anteriormente não sejam atendidas, o Portal do Cliente exibirá uma mensagem informando que o ambiente está desatualizado para o usuário.

 

Solução
O Portal do Cliente permitirá o download do DANFE e do XML apenas para as notas fiscais que foram devidamente transmitidas e autorizadas pela SEFAZ (Secretaria de Estado da Fazenda).

Para notas do tipo NFS-e (Nota Fiscal de Serviço Eletrônica), essa funcionalidade será desabilitada.

Ressaltamos que algumas premissas devem ser previamente atendidas para o correto funcionamento deste recurso. Tais configurações são de responsabilidade do administrador do ambiente.

 

Protheus

  1. O serviço REST do Protheus deve estar devidamente ativo.
  2. A integração com o TSS (TOTVS Service SOA) deve estar corretamente configurada.

Para mais informações, acesse a documentação oficial.

Configurações Gerais do TSS


O parâmetro MV_FNPCTSS deve ser configurado com o endereço do servidor REST do TSS, no seguinte formato:
[seu_ip]:[sua_porta]/[caminho_rest]

Exemplo: 192.168.0.1:8080/tss/rest/

 

3- O parâmetro MV_SPEDGRV deve ter conteúdo igual a 2 

Para mais informações, acesse a documentação oficial.

Criação do parâmetro MV_SPEDGRV para preencher a tag GRVDOCAUX do método DISTRIBUICAODEDOCUMENTOS.

4- Para Protheus 12.1.2310 ou versões anteriores:
O ambiente deve estar atualizado com o Pacote de Expedição Contínua (PEC) do Backoffice, conforme as seguintes datas mínimas:

  • Superior a 15/01/2024 para integração com o TSS 12.1.2310.
  • Superior a 15/09/2024 para integração com o TSS 12.1.2410.

Além disso, a autenticação via segurança de socket deve estar habilitada, configurando o parâmetro security=1.

Para mais informações, consulte a documentação oficial.

WebServices REST/Server - Configuração)

 

TSS

  1. O serviço REST do TSS deve estar devidamente ativo.
  2. Para o TSS 12.1.2310 ou versões anteriores:
    • O ambiente deve possuir o endpoint end-point tssapidoc/v1/nfe/retornadoc/.
      Para validar a existência do endpoint, acesse pelo navegador o endereço:
      http://[seu_ip]:[sua_porta]/[caminho_rest]/tssapidoc/v1/nfe/retornadoc/
    • É necessário que o ambiente esteja atualizado com o Pacote de Expedição Contínua (PEC) com data superior a 04/01/2024.
    • A autenticação via segurança de socket deve estar desabilitada, configurando o parâmetro security=0.

 

Importante
A partir da release 12.1.2410, a autenticação via segurança de socket será obrigatoriamente habilitada, tanto no Protheus quanto no TSS.

Para mais informações, consulte a documentação oficial.

Framework - Bloqueio de REST e SOAP sem security)

 

Resumo das Ações Necessárias em Relação ao TSS:

  1. Validar se, ao acessar o serviço REST do TSS, o endpoint EndPoint tssapidoc/v1/nfe/retornadoc/ está disponível.

    Caso o endpoint não seja apresentado, será necessário realizar a atualização do RPO do TSS.

Resumo das ações a serem tomadas quanto ao TSS:

1 - Validar se ao acessar o Rest do TSS ira apresentar o EndPoint tssapidoc/v1/nfe/retornadoc/

Se não apresentar este EndPoint, significa que será necessário atualizar o RPO do TSS.

 

Como validar: Acesse, através do navegador, o seguinte endereço:
 http://seuip:suaporta/caminhorest/tssapidoc/v1/nfe/retornadoc/ 
 
2. O endereço do serviço REST do TSS deve ser configurado no parâmetro MV_FNPCTSS.

 

Importante

 O endereço informado deve ser o mesmo utilizado na validação descrita no item 1 (REST do TSS).

 

Saiba mais

Portal do Cliente
Funcionalidades - Portal do cliente

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _