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Cross Segmentos - TOTVS Backoffice (Linha Protheus) - Financeiro - Contas a Receber - FINA713 - Monitor a registrar para clientes cloud

time.png Tempo aproximado para leitura: 00:10:00 min

Ocorrência
No módulo Financeiro, ao tentar realizar a transmissão de recebimentos, no Monitor de pendências fica com status "A Registrar"

 



Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - Todas as versões homologadas

Causa
Este incidente ocorre devido à configuração incorreta do sistema para o JOB FINA713, que é o responsável pelo envio das cobranças online.


Cenários de ocorrência deste erro:

1 - JOB CADASTRADO SEM GRUPO DE EMPRESAS  

Documentação

Configuração dos Jobs (Comunicação bancaria online)

 

Solução
O JOB deve ser configurado com o código do Grupo de Empresas informado como parâmetro.

Exemplo: Para o grupo de empresas com o código 01, a configuração será: FINA713('01').

 

Cenários de ocorrência deste erro:
2 - JOB CADASTRADO COM MAIS DE UMA FILIAL 

Documentação

Configuração dos Jobs (Comunicação bancaria online)

Solução
A configuração dos JOBs deve ser realizada de forma individual por Grupo de Empresas, sendo necessário cadastrar apenas um agendamento para uma única filial.

Cenários de ocorrência deste erro:

3 - TABELA XX1 COM DUPLICIDADE DA ROTINA FINA713 

Em muitos casos, as bases são clonadas e com isso, os dados de outros ambientes são levados para as tabelas de agendamento (XX0/XX1), um ambiente que o campo XX1_ENV é diferente, não é apresentado, porém, causa erro no envio da cobrança, pois se trata de uma função que recebe o parâmetro de Grupo de empresas.

 

Solução
Deve-se verificar a existência de outros JOBs cadastrados nas tabelas XX0/XX1 e realizar a remoção dos registros indevidos.

 

Cenários de ocorrência deste erro:

4 - AGENTE PARADO NO SERVIÇO DE SCHEDULE 

 

Caso esteja sendo utilizado o serviço de fila Scheduler (e não o novo serviço Smart Scheduler), deve-se verificar no cadastro de agentes se:

  • O agente está devidamente cadastrado e inicializado na URL/porta do servidor de Schedule;

  • O código do agente está configurado para o Grupo de Empresas correto.

Segue exemplo abaixo:



 

Importante
Caso o agente esteja sendo criado para outro codigo / url do servidor diferente do seu serviço de Schedule (Geralmente Porta 6800)

 

Solução

É necessário excluir o agente existente, certificar-se de que o usuário está devidamente logado no serviço de Schedule (WF) e, em seguida, criar um novo agente através do caminho: Outras Ações > Criar agentes padrões.

Exemplo de login no WF




Importante

Caso o ambiente seja 12.1.2410, deve acessar a URL do Schedule, caso não tenha conhecimento sobre a URL, solicitar ao CLOUD via atendimento

Obs: Caso o ambiente esteja usando o SMARTSCHEDULE não é necessário o uso de agentes

 

Cenários de ocorrência deste erro:

5 - JOB FINA713 SEM FILIAL CADASTRADA (XX2)


 

Documentação

Configuração dos Jobs (Comunicação bancaria online)

A configuração dos jobs deve ser única por Grupo de Empresas. sendo necessário cadastrar apenas um agendamento para uma filial.

Exemplo:

Empresa T1

Filiais: D MG 01 , D MG 02 , D RJ 01 , D RJ 02 , D SP 01 , D SP 02

Apenas 1 cadastro de agendamento no schedule para 1 Empresa/Filial para que o schedule execute apenas 1 chamada e fique a cargo do job executar para o grupo de empresas todo.

Empresa/Filial = T1/D MG 01 ; → Correto

Empresa/Filial = T1/D MG 01 ;T1/D MG 02 ;T1/D RJ 01 ; → Incorreto

Empresa/Filial = T1; → Incorreto → schedule executa chamada para todas as filiais.


Solução

Deve acessar a rotina e cadastrar uma filial central para que possa executar corretamente.

 

6 - LAYOUT DE CONFIGURAÇÃO COM CUSTOMIZAÇÕES INCORRETAS 

A configuração de contas em Novo Gestor Financeiro (FINA710) - Comunicação Bancaria, pode estar com sintaxes invalidas em ADVPL como, funções, somas, informações de numeros passando virgula, entre outros.

Solução

Deve-se verificar se há alterações nos campos padrão e, se necessário, ajustá-los para os valores originais. Em seguida, realizar um novo teste. Caso o envio ocorra corretamente, recomenda-se revisar a codificação implementada.

 

Cenários de ocorrência deste erro:

7 - LAYOUT COM VALOR DE ABATIMENTO VAZIO

Configuração de Contas >> FINA710 - Comunicação Bancária

SOLUÇÃO

No Protheus, é necessário que o campo Valor de Abatimento em alguns bancos seja preenchido, certifique-se que o campo Valor Abatimento está preenchido na configuração de contas

Saiba mais
Contas a receber (Comunicação bancária online)
Configuração dos Jobs (Comunicação bancaria online)
Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - FINA713 - Configuração e Funcionalidade da transmissão de boletos API

 

 

 

 

 

 

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