Tempo aproximado para leitura: 00:01:35 min
Ocorrência
Ao tentar cancelar uma OM - Ordem de montagem no VDP1410 - Cancelamento Ordem Montagem/Romaneio ocorre a mensagem: Registro não encontrado na ped_itens.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Logística e Distribuição - Versão 12
Causa
Essa mensagem ocorre quando o código de um item do pedido é alterado após a geração da OM.
Solução
Para poder cancelar a OM o código do item no pedido terá que ser alterado para o código original quando a OM foi gerada.
Será necessário comparar os itens da OM no VDP2510 - Consulta de OM, e os itens do pedido no VDP20000 - Manutenção de pedidos, e verificar quais itens foram alterados.
Outra forma forma de verificar é consultando a auditoria de pedidos no VDP20028 - Consulta auditoria de vendas e verificar as mensagens que indiquem alteração de código do item do pedido.
Após a alteração para o mesmo código de item, que está sendo usado na OM, será possível realizar o cancelamento.
Saiba Mais
Se desejar impedir que o pedido seja alterado quando tiver OM ou pedido faturado, consulte os artigos abaixo. Para impedir alteração de pedido com OM gerada:
Cross Segmentos - Linha Logix - PED - Parametrização necessária para que o pedido não seja alterado quando já tiver OM gerada
Para impedir alteração de pedido faturado:
Cross Segmentos - Linha Logix - PED - Permitir alteração de itens faturados completamente
0 Comentários