Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MB - MB_PORTAL - Object must implement IConvertible

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao Sincronizar os serviços do utilizando o aplicativo Hibrido e que integra as suas informações ao TOTVS Agro Multicultivo é apresentado quando clica no serviço de Tipo Apontamentos Diversos o erro "Object must implement IConvertible"





Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Portal Mobilidade - MB_PORTAL - Todas as versões

Causa
O problema é ocasionado, pois no serviço /multicultivo?tipoAptoDiversos esta com o campo Icone com o Type igual a System.String e o correto é System.Byte[]

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o Portal Mobilidade;

2. Encontre a aba MULTICULTIVO_CADASTROS;

3. Nessa aba encontre o serviço Tipo de Apontamentos Diversos;

4. Edite esse serviço e nele acesse a aba CAMPOS;

5. Realize a alteração do tipo do campo Icone de System.String para System.Byte[];

4. Salve a alteração e realize uma nova sincronização do aplicativo.

 



 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _