Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Duplicação na execução de Dataset devido a problema de ClassLoader

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Durante a execução do dataset, ocorre uma duplicação na chamada. No log, é registrada a seguinte mensagem: "Possível problema de classloader na execução do dataset dsX. Tentando novamente..." Mas por que isso acontece?

Ambiente
TOTVS Fluig Plataforma - Desenvolvimento sobre a Plataforma - Todas as versões

Causa

Essa mensagem geralmente indica que o dataset está sendo executado mais de uma vez sem um controle adequado para evitar a duplicação.

Algumas possíveis causas incluem:

  • Ausência de controle de execução: O dataset pode estar sendo chamado novamente sem validação prévia.

  • Uso incorreto da função addRow: A função addRow deve receber um array de strings. Problemas podem ocorrer, por exemplo, quando é passado um objeto JSON diretamente, como em:
    dataset.addRow(new Array({teste: 1}));

  • Problemas de classloader: A mensagem pode estar relacionada a:

    • Código mal estruturado ou com erros;

    • Problemas de cache (arquivos temporários corrompidos ou desatualizados);

    • Retornos não tratados corretamente;

    • Conflito entre bibliotecas utilizadas no dataset.

Solução

  • Revise o código do dataset, garantindo que haja uma lógica que evite a reexecução desnecessária.

  • Implemente um controle de chamada, verificando se o dataset já foi executado anteriormente.

  • Garanta que o addRow utilize apenas arrays com valores do tipo string.

  • Limpe o cache da aplicação, se necessário, para eliminar arquivos temporários que possam estar interferindo na execução.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _