Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro na geração do S-1200 e S-2299: O valor do campo 'nrDoc' do registro 'descFolha' excedeu o tamanho do campo e foi truncado


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao gerar os eventos S-1200/S-2299 é apresentada a mensagem: O valor do campo 'nrDoc' do registro 'descFolha' excedeu o tamanho do campo e foi truncado
 

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - eSocial - Todas as versões 

Causa 
O erro ocorre devido não possuir uma versão ou patch que contempla as novas validações da tag nrDoc que permite de 1 a 15 dígitos informados no campo, número do contrato referente ao empréstimo.

Sendo assim, como não atualizou para um versão vigente ou patch, o sistema ainda fica mantendo a antiga validação que era 8 dígitos.

Segue Manual de Orientação do eSocial: 


Solução
1. Para corrigir o erro mencionado na geração do XML, é necessário atualizar para as versões e patches a seguir:

12.1.2406.277, 12.1.2410.229, 12.1.2502.145, 12.1.2506 ou superiores.
 

2. É necessário atualizar o campo abaixo com a nova Nota Técnica, a fim de atender às validações exigidas no layout vigente:




 

Link Central de Downloads: Downloads e Atualizações


Saiba mais
Para mais informações, acesse: 
TOTVS RH Informa

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _