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Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - ANDROID - Sincronização - Sincronização cancelada: versão dos dados não foi encontrada na configuração da sincronização

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao realizar a sincronização no aplicativo, não sendo esta a primeira realizada no aparelho (a que é realizada no processo de instalação), ocorre o erro abaixo:

ASTSIN_0016 - A sincronização foi cancelada. Motivo: A versão dos dados do dispositivo não foi encontrada na configuração da sincronização (lib_old). Por favor, entre em contato com o responsável pela sincronização.


Ambiente
Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - ANDROID - Sincronização - Todas as versões

Causa
Este erro ocorre devido a versão do aplicativo instalado ser diferente da versão da sincronização. Nesse caso, apenas a limpeza do aplicativo no aparelho não é suficiente para deletar os dados da versão que está diferente, sendo necessário realizar o ajuste no servidor também.

Solução

Atenção!
O processo abaixo deve ser seguido somente se, após a limpeza de dados do aplicativo o problema continuar ocorrendo. 


1. Realize a limpeza de dados e a desinstalação do aplicativo Meu SFA, conforme documentação a seguir:

Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - ANDROID - Acesso/Login - Desinstalação do aplicativo Meu SFA


2. No servidor, abra o explorador de arquivos e vá até a pasta sincronização.


3. Para localizar as dats referentes ao usuário que está com o problema na sincronização, será preciso ter o id do profissional. Você pode encontrar a informação no fim da url da web na edição do profissional, conforme abaixo:

 

4. Dentro de dats, você deve procurar pela pasta com o id do usuário. Após localizar, pode selecionar todas as pastas com o idusuario que está com problema e deletar.

  • uid: id do usuário
  • dvid: id do aparelho

 

Importante!
Caso o servidor seja Linux, pode não ser possível excluir os arquivos diretamente pelo gerenciador. Caso isso ocorra, será necessário fazer a remoção dos arquivos via linha de comando (terminal). 

 

5. Após esse processo, basta reinstalar o aplicativo e realizar uma nova sincronização

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