Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro de Schema instFinanc na transmissão dos eventos S-2299/S-1200 com o Governo

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência
Ao transmitir S-2299 ao Governo é apresentada a mensagem Erro de schema: Element '{http://www.esocial.gov.br/schema/evt/evtDeslig/v_S_01_03_00}instFinanc': [facet 'pattern'] The value '79' is not accepted by the pattern '\d{3}'.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - eSocial - Todas as versões

Causa 
O erro ocorre quando existe desconto de empréstimo relacionado ao Crédito do Trabalhador nos XML's S-1200/S-2299, e foi informado no cadastro do empréstimo, no campo 'Código do banco concedente do empréstimo' um código com 2 dígitos, porém conforme o leiaute do eSocial S-1.3 NT 03/2025, é necessário informar um código com 3 dígitos:

 

 

Segue o trecho do leiaute demonstrando a obrigatoriedade de 3 dígitos:

Solução
Para solucionar o erro de schema, realize os seguintes passos:

1. Acesse Administração de Pessoal | Anexos | Folha de Pagamento | Empréstimos
2. Selecione o empréstimo do Crédito do Trabalhador
3. Ajuste o campo Código do banco concedente do empréstimo, informando um código com 3 dígitos
4. Localize o evento com erro, e regere-o antes de enviar.

 

Saiba Mais:

No link abaixo, você encontrará o link para a Tabela 37 do eSocial onde constam os códigos de Banco de acordo com o Banco Central:
Tabelas do eSocial

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _